KBEngine官方论坛

 立即注册

QQ登录

只需一步,快速开始

搜索
热搜: 配置 开服
查看: 105|回复: 9

centos7.3 启动kbe失败了,求救。

[复制链接]

10

主题

40

帖子

174

积分

注册会员

Rank: 2

积分
174
发表于 2019-1-11 00:23:04 | 显示全部楼层 |阅读模式
本帖最后由 ybyaoyao 于 2019-1-11 00:29 编辑

[root@host assets]# log4cxx: No appender could be found for logger ().
log4cxx: Please initialize the log4cxx system properly.
   unknown-1: [ERROR]: TiXmlNode::openXML: /root/kbengine-1.2.7/assets/res/server/kbengine.xml, error!
   unknown-1: [ERROR]: ServerConfig::loadConfig: load server/kbengine.xml is failed!

老大些 给指条路吧。
我对linux不太熟。。。
这个是因为log4cxx没安好?加载配置xml也加载不了。
回复

使用道具 举报

10

主题

40

帖子

174

积分

注册会员

Rank: 2

积分
174
 楼主| 发表于 2019-1-11 10:11:02 | 显示全部楼层
我把文档上该配置的那些目录配置一下看看。
回复

使用道具 举报

5

主题

4507

帖子

214748万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
2147483647

引擎扛把子

发表于 2019-1-11 10:14:37 | 显示全部楼层
你自己确认下/root/kbengine-1.2.7/assets/res/server/kbengine.xml这个路径对?
QQ:3603661
3603661@qq.com
回复

使用道具 举报

10

主题

40

帖子

174

积分

注册会员

Rank: 2

积分
174
 楼主| 发表于 2019-1-11 11:26:41 | 显示全部楼层
本帖最后由 ybyaoyao 于 2019-1-11 16:28 编辑
柯标 发表于 2019-1-11 10:14
你自己确认下/root/kbengine-1.2.7/assets/res/server/kbengine.xml这个路径对?

我把kbengine-1.2.7目录改了 改成了kbengine了,然后 bashrc也配置了,还是不行

#============================
# .bashrc

# User specific aliases and functions

alias rm='rm -i'
alias cp='cp -i'
alias mv='mv -i'

# Source global definitions
if [ -f /etc/bashrc ]; then
        . /etc/bashrc
fi


ulimit -c unlimited
export KBE_ROOT=~/kbengine/
export KBE_RES_PATH=$KBE_ROOT/kbe/res/:$KBE_ROOT/assets/:$KBE_ROOT/assets/scripts/:$KBE_ROOT/assets/res/
export KBE_BIN_PATH=$KBE_ROOT/kbe/bin/server/
#==========================================


[root@host assets]# sh start_server.sh
KBE_ROOT = "/root/kbengine"
KBE_RES_PATH = "/root/kbengine/kbe/res/:/root/kbengine/assets:/root/kbengine/assets/res:/root/kbengine/assets/scripts/"
KBE_BIN_PATH = "/root/kbengine/kbe/bin/server/"
[root@host assets]# log4cxx: No appender could be found for logger ().
log4cxx: Please initialize the log4cxx system properly.
   unknown-1: [ERROR]: TiXmlNode::openXML: /root/kbengine/assets/res/server/kbengine.xml, error!
   unknown-1: [ERROR]: ServerConfig::loadConfig: load server/kbengine.xml is failed!


这个路径是有一个资产库的xml配置文件的
/root/kbengine/assets/res/server/kbengine.xml

[root@host assets]# cd /root/kbengine/assets/res/server/
[root@host server]# ls
kbengine.xml  log4cxx_properties  server_errors.xml
[root@host server]#



另外我看到文档上面有这个
Linux:(假设引擎安装目录为 root/kbengine)

[kbe @gameserver ~]$ cd root/kbengine/getstarted_assets
[kbe @gameserver ~]$ sh start_server.sh
[kbe @gameserver ~]$ sh kill_server.sh





cd root/kbengine/getstarted_assets ,不会跟这个有关吧,这个目录我没有啊, 1.2.7版的最简assets应该也能启动的撒。


回复

使用道具 举报

5

主题

4507

帖子

214748万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
2147483647

引擎扛把子

发表于 2019-1-11 12:05:05 | 显示全部楼层
是不是kbengine.xml格式
有错误啊?
QQ:3603661
3603661@qq.com
回复

使用道具 举报

5

主题

4507

帖子

214748万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
2147483647

引擎扛把子

发表于 2019-1-11 12:05:53 | 显示全部楼层
一般来说不需要设置环境变量, 直接在assets中启动就好了, 脚本会自动设置。
你可以把环境变量都去掉。
重启系统, 再测试, 检查一下xml是不是改出问题了。
QQ:3603661
3603661@qq.com
回复

使用道具 举报

10

主题

40

帖子

174

积分

注册会员

Rank: 2

积分
174
 楼主| 发表于 2019-1-11 17:43:22 | 显示全部楼层
环境变量去掉,然后更换一个xml文件就可以了,貌似xml里面有问题。
谢谢谢谢。
回复

使用道具 举报

5

主题

4507

帖子

214748万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
2147483647

引擎扛把子

发表于 2019-1-11 18:03:33 | 显示全部楼层
这个xml哪来的?
QQ:3603661
3603661@qq.com
回复

使用道具 举报

5

主题

4507

帖子

214748万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
2147483647

引擎扛把子

发表于 2019-1-11 18:03:38 | 显示全部楼层
你改过?
QQ:3603661
3603661@qq.com
回复

使用道具 举报

10

主题

40

帖子

174

积分

注册会员

Rank: 2

积分
174
 楼主| 发表于 2019-1-11 21:10:52 | 显示全部楼层

xml我改过的。加了数据库访问 外网ip这些。后来我检查了一下,xml 在linux上改的时候有个地方少了个 >
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版|小黑屋|KBEngine Forum

GMT+8, 2019-3-22 21:19 , Processed in 0.029117 second(s), 22 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表