KBEngine官方论坛

 立即注册

QQ登录

只需一步,快速开始

搜索
热搜: 配置 开服
查看: 1007|回复: 11

关于warning升级unity5的一些经验

[复制链接]

33

主题

110

帖子

684

积分

高级会员

Rank: 4

积分
684
发表于 2016-12-10 22:29:27 | 显示全部楼层 |阅读模式
自己进行了一些尝试,实在能力有限,无法完成
但是自己搞了这么久啥也不留下实在不甘心,整理了自己的一些经验和目前改成的部分
希望对后来要搞这个的有帮助

经验&部分修改后的源码地址:https://git.oschina.net/firesuir ... ob/master/README.md

Firesuiry 2016年12月10日22:29:07

回复

使用道具 举报

30

主题

7138

帖子

1万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
16457
QQ
发表于 2016-12-12 08:27:30 | 显示全部楼层
辛苦
热爱游戏、热爱开源!
柯标
3603661@qq.com

柯标
3603661@qq.com
回复

使用道具 举报

4

主题

43

帖子

128

积分

注册会员

Rank: 2

积分
128
发表于 2017-5-29 18:59:40 | 显示全部楼层
非常好,辛苦了,我本来也尝试着要把这个demo升级成unity5
回复

使用道具 举报

33

主题

110

帖子

684

积分

高级会员

Rank: 4

积分
684
 楼主| 发表于 2017-6-3 19:53:39 | 显示全部楼层
jdknight 发表于 2017-5-29 18:59
非常好,辛苦了,我本来也尝试着要把这个demo升级成unity5

加油~~~~~~~~~~~~~~
回复

使用道具 举报

4

主题

43

帖子

128

积分

注册会员

Rank: 2

积分
128
发表于 2017-8-18 23:07:03 | 显示全部楼层
TextEditor.这个类找不到。还有scenemanager这个space也报错找不到。是不是工程里面少了点东西?
回复

使用道具 举报

4

主题

43

帖子

128

积分

注册会员

Rank: 2

积分
128
发表于 2017-8-18 23:23:05 | 显示全部楼层
是不是要把ngui的脚本都要拷贝进去?
回复

使用道具 举报

4

主题

43

帖子

128

积分

注册会员

Rank: 2

积分
128
发表于 2017-8-18 23:26:18 | 显示全部楼层
TextEditor这个构造体是ngui里面的么?TextEditor.text报错,说TextEditor里text这个元素不存在啊
回复

使用道具 举报

4

主题

43

帖子

128

积分

注册会员

Rank: 2

积分
128
发表于 2017-8-18 23:37:38 | 显示全部楼层
EditorSceneManager.OpenScene(name);??为什么不是application.loadlevel?这个是自己写的加载场景方式?问题是UnityEditor里根本找不到啊
回复

使用道具 举报

4

主题

43

帖子

128

积分

注册会员

Rank: 2

积分
128
发表于 2017-8-18 23:43:26 | 显示全部楼层
查api搞明白了,SceneManagement'5.3版本才开始支持,我的是5。0。要升级unity才行,误会了,我升级unity再继续吧
回复

使用道具 举报

33

主题

110

帖子

684

积分

高级会员

Rank: 4

积分
684
 楼主| 发表于 2017-8-23 23:24:13 | 显示全部楼层
jdknight 发表于 2017-8-18 23:26
TextEditor这个构造体是ngui里面的么?TextEditor.text报错,说TextEditor里text这个元素不存在啊 ...

我把ngui版本升级了一下,,具体的我也不太清楚,升级完以后关于ui的问题基本上都正常了
回复

使用道具 举报

33

主题

110

帖子

684

积分

高级会员

Rank: 4

积分
684
 楼主| 发表于 2017-8-23 23:24:58 | 显示全部楼层
jdknight 发表于 2017-8-18 23:43
查api搞明白了,SceneManagement'5.3版本才开始支持,我的是5。0。要升级unity才行,误会了,我升级unity再 ...

嗯嗯 加油 :)
回复

使用道具 举报

4

主题

43

帖子

128

积分

注册会员

Rank: 2

积分
128
发表于 2017-8-24 21:07:21 | 显示全部楼层
查api搞明白了,SceneManagement'5.3版本才开始支持,我的是5。0。要升级unity才行,误会了,我升级unity再继续吧
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版|小黑屋|KBEngine Forum

GMT+8, 2018-12-10 18:22 , Processed in 0.073643 second(s), 22 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表