KBEngine官方论坛

 立即注册

QQ登录

只需一步,快速开始

搜索
热搜: 配置 开服
查看: 887|回复: 3

kbengine_unity3d_warring-0.8.3里的JS文件报错怎么办

[复制链接]

2

主题

7

帖子

38

积分

新手上路

Rank: 1

积分
38
发表于 2016-5-21 11:14:35 | 显示全部楼层 |阅读模式
在Unity5.3 里打开kbengine_unity3d_warring-0.8.3,修改了一些过时的函数后报了一堆这种错,不知道怎么办

Assets/thirdparty/ShurikenMagic/Scripts/SM_animRandomizer.js(11,1): BCE0048: Type 'UnityEngine.Component' does not support slicing.


回复

使用道具 举报

2

主题

7

帖子

38

积分

新手上路

Rank: 1

积分
38
 楼主| 发表于 2016-5-21 11:33:53 | 显示全部楼层
知道了,就是要把Animation 替换成
GetComponent.<Animation>()
回复

使用道具 举报

30

主题

7138

帖子

1万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
16457
QQ
发表于 2016-5-21 13:41:01 | 显示全部楼层
只能用u3d 4.x,这个demo
热爱游戏、热爱开源!
柯标
3603661@qq.com

柯标
3603661@qq.com
回复

使用道具 举报

2

主题

7

帖子

38

积分

新手上路

Rank: 1

积分
38
 楼主| 发表于 2016-5-22 15:42:28 | 显示全部楼层
知道了,下载了4.7,就全部正常了
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版|小黑屋|KBEngine Forum

GMT+8, 2018-12-10 19:55 , Processed in 0.097106 second(s), 22 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表