KBEngine官方论坛

 立即注册

QQ登录

只需一步,快速开始

搜索
热搜: 配置 开服
查看: 2381|回复: 13

unity3d客户端warring-demo问题(一直提示: "加载周围环境,请稍...

[复制链接]

3

主题

8

帖子

35

积分

新手上路

Rank: 1

积分
35
发表于 2015-2-13 11:32:43 | 显示全部楼层 |阅读模式
进入游戏场景后,一直停留在"加载周围环境,请稍候...",这是为什么呢?
回复

使用道具 举报

2

主题

9

帖子

36

积分

新手上路

Rank: 1

积分
36
发表于 2015-2-13 11:36:17 | 显示全部楼层
确认是否已经配置:https://github.com/kbengine/kbengine_unity3d_warring/
配置Demo:
创建AssetBundles(默认已经创建,可以跳过这一步):
    unity3d(菜单上)->Publish->Build Publish AssetBundles(打包所有需要动态加载资源)

    期间可能一直出现"Moving file failed", 需要点击"try again"让其继续,
    这可能是unity3d在移动文件时文件被占用造成的。
    执行完毕后检查 Assets->StreamingAssets是否有内容。

生成服务端寻路数据(默认已经创建,可以跳过这一步):
    先将Assets\Plugins\cai-nmgen-rcn(generate navmesh).zip解压放当前目录下并重启unity3d编辑器, 然后执行如下步骤:
        unity3d资源浏览器中选中(非菜单): Assets->Nav_build->xinshoucun->NavmeshBuild->Build & Bake, 等待生成完成之后
        unity3d资源浏览器中选中(非菜单): Assets->Nav_build->xinshoucun->CAIBakedNavmesh->Save, 将其中srv_xxx.navmesh放到服务端kbengine\kbengine_demos_assets\res\spaces\xinshoucun中
    (注意: 生成完毕后建议删除cai-nmgen-rcn(generate navmesh).zip解压出来的文件,会造成无法导出游戏的错误,原因未知。)
回复

使用道具 举报

30

主题

7138

帖子

1万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
16457
QQ
发表于 2015-2-13 11:38:33 | 显示全部楼层
请注明unity的版本, 4.6.2及以下版本没有问题, u3d5.0就不一定了。
以及warring是否是最新的。
最近针对这个问题修复过一次。

楼上说的也是一种情况,都检查一下。
热爱游戏、热爱开源!
柯标
3603661@qq.com

柯标
3603661@qq.com
回复

使用道具 举报

3

主题

8

帖子

35

积分

新手上路

Rank: 1

积分
35
 楼主| 发表于 2015-2-13 11:38:38 | 显示全部楼层
生成服务端寻路数据(默认已经创建,可以跳过这一步)
从git上下来的,这个都已经有了,必须重新做一遍?
回复

使用道具 举报

3

主题

8

帖子

35

积分

新手上路

Rank: 1

积分
35
 楼主| 发表于 2015-2-13 11:39:33 | 显示全部楼层
我重新做一遍吧
回复

使用道具 举报

30

主题

7138

帖子

1万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
16457
QQ
发表于 2015-2-13 11:39:57 | 显示全部楼层
检查warring版本吧, 上周修复的。
热爱游戏、热爱开源!
柯标
3603661@qq.com

柯标
3603661@qq.com
回复

使用道具 举报

3

主题

8

帖子

35

积分

新手上路

Rank: 1

积分
35
 楼主| 发表于 2015-2-13 11:56:44 | 显示全部楼层
我昨天git pull的最新版的,unity3d 4.6.2
回复

使用道具 举报

30

主题

7138

帖子

1万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
16457
QQ
发表于 2015-2-13 12:56:03 | 显示全部楼层
davidfoxhu 发表于 2015-2-13 11:38
生成服务端寻路数据(默认已经创建,可以跳过这一步)
从git上下来的,这个都已经有了,必须重新做一遍? ...

git下来有了是不用创建的, 可选项目不需要操作。
热爱游戏、热爱开源!
柯标
3603661@qq.com

柯标
3603661@qq.com
回复

使用道具 举报

30

主题

7138

帖子

1万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
16457
QQ
发表于 2015-2-13 13:20:31 | 显示全部楼层
davidfoxhu 发表于 2015-2-13 11:56
我昨天git pull的最新版的,unity3d 4.6.2

插件都更新了没有?
可以将u3d编辑器的日志贴上来。
热爱游戏、热爱开源!
柯标
3603661@qq.com

柯标
3603661@qq.com
回复

使用道具 举报

54

主题

158

帖子

531

积分

高级会员

Rank: 4

积分
531
发表于 2015-3-16 14:26:49 | 显示全部楼层
warring的插件在哪里?下载的服务器里,assert基本是空的。
回复

使用道具 举报

30

主题

7138

帖子

1万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
16457
QQ
发表于 2015-3-16 14:30:30 | 显示全部楼层
readme里有写https://github.com/kbengine/kbengine_unity3d_plugins
最好详细看一遍, 还有其他需要注意的
热爱游戏、热爱开源!
柯标
3603661@qq.com

柯标
3603661@qq.com
回复

使用道具 举报

4

主题

10

帖子

64

积分

注册会员

Rank: 2

积分
64
发表于 2015-8-20 15:40:23 | 显示全部楼层
我也是遇到过,后来换了版本就好了。
回复

使用道具 举报

10

主题

36

帖子

202

积分

中级会员

Rank: 3Rank: 3

积分
202
发表于 2016-11-24 12:36:21 | 显示全部楼层
我也出现这种情况,用4.6.2的unity版本还是一样
回复

使用道具 举报

8

主题

3374

帖子

7586

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
7586
QQ
发表于 2016-11-24 13:00:23 | 显示全部楼层
penggang0813 发表于 2016-11-24 12:36
我也出现这种情况,用4.6.2的unity版本还是一样

http://bbs.kbengine.org/forum.ph ... &extra=page%3D1
柯标
3603661@qq.com
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版|小黑屋|KBEngine Forum

GMT+8, 2018-12-10 18:47 , Processed in 0.037258 second(s), 22 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表